Carr's Compendiums: System Requirements (Minimum)

The following system requirements are based on the minimum system requirements needed to run a Carr's Compendium compatible browser.

Windows


Macintosh


Linux


Recommended for all Systems

Products and company names mentioned herein may be the trademarks of their respective owners.

Return to top of page